The release to the AP, CA and NA has been completed.
Posted Jul 07, 2025 - 01:08 UTC
Update
The release to the EU has been completed.
Posted Jul 03, 2025 - 02:12 UTC
Scheduled
Version v1.6.2 of the Ricoh CloudStream Device Management Cloud is scheduled for release.
[Release Schedule] NA: July 7, 2025 UTC EU: July 3, 2025 UTC AP: July 7, 2025 UTC CA: July 7, 2025 UTC
While we expect no downtime during the release dates, customers may experience brief interruptions in service when connected clients reconnect locally.