The release to the EU, AP and CA has been completed.
Posted 22 days ago. May 01, 2025 - 06:41 UTC
Update
The release to the NA has been completed.
Posted 23 days ago. Apr 30, 2025 - 04:00 UTC
Scheduled
Version 1.6.0 of the Ricoh CloudStream Device Management Cloud is scheduled for release.
[Release Schedule] NA: April 30, 2025 UTC EU: May 1, 2025 UTC AP: May 1, 2025 UTC CA: May 1, 2025 UTC
While we expect no downtime during the release dates, customers may experience brief interruptions in service when connected clients reconnect locally.