Version v1.7.3 of the Ricoh CloudStream Device Management Cloud is scheduled for release.
[Release Schedule] AP: December 23, 2025 UTC CA: December 23, 2025 UTC
While we expect no downtime during the release dates, customers may experience brief interruptions in service when connected clients reconnect locally.
Posted Dec 22, 2025 - 05:58 UTC
Update
The release to the EU has been completed.
The release to the AP and CA has been rescheduled. The new release schedule will be announced at a later time.
Posted Dec 18, 2025 - 08:31 UTC
Update
The release to the NA has been completed.
Posted Dec 17, 2025 - 06:24 UTC
Scheduled
Version 1.7.3 of the Ricoh CloudStream Device Management Cloud is scheduled for release.
[Release Schedule] NA: December17, 2025 UTC EU: December18, 2025 UTC AP: December18, 2025 UTC CA: December18, 2025 UTC
While we expect no downtime during the release dates, customers may experience brief interruptions in service when connected clients reconnect locally.